F.A.Q.

What is the minimum iOS version the device supports.
iOS version 6 or above. Please download the i-Beamer Laser Pointer app from your device's App Store.
Does it work with Android phones?
No. The current version support iOS only.
Can I control PowerPoint with it?
You can download i-Clickr Remote app to control your PowerPoint and Keynote presentation. This app has built-in support to i-Beamer Laser Pointer.